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Modeling a Harmonic Oscillator

This tutorial illustrates many of the basic techniques for constructing and executing
models in Berkeley Madonna. We’ll begin by creating a simple model using the equation
editor and exploring its run-time behavior. Then, in    Building a Visual Model   , we’ll create
a graphical model using Madonna’s new flowchart editor.

1. Launch Berkeley Madonna. Choose New from the File menu. Madonna creates a new
model and opens its equation window. Edit the equations to appear as follows (changes
are in bold):

METHOD Euler

STARTTIME = 0
STOPTIME = 10
DT = 0.1

init A = 0
init B = 1
d/dt(A) = -k1*B
d/dt(B) = k2*A
k1 = 1.0
k2 = 1.0

Tip: choose Equation Help from the Help menu for a summary of Berkeley Madonna’s
equation syntax.

2. Choose Run from the Compute menu (or click the Run button). Berkeley Madonna
runs your model and plots the results for variables A and B.

3. Note that the amplitude of oscillation for both A and B increase over time. This
instability is due to the fact that Euler’s method is accurate to only the first order. Using
the Compute menu, change the integration method to Runge-Kutta 2 and run the
model again. Now the amplitude is almost perfectly stable.

4. Open the parameter window by choosing Parameter Window from the Parameters
menu. Select STOPTIME and change it to 1000. (Hint for Windows users: if you double-
click a parameter in the list, you can immediately type in a new value without having
to select the text in the edit field.) Run the model again. You’ll see that the amplitude is
actually increasing over time, albeit very slowly. If you change the integration method
to Runge-Kutta 4, the amplitude will be absolutely stable (try it).

5. With over ten thousand data points shown in the plot, it’s hard to see the individual
oscillations. With the zoom-in feature, you can magnify any portion of the plot to fill



the entire screen. Using the left mouse button, drag a rectangle over a small portion of
the plot, then release the mouse button. You can repeatedly zoom-in as many times as
you want.

6. While you’re zoomed in, try clicking some of the buttons in the toolbar above the plot:

Table: displays the results of the run in tabular form. Tables can be saved and copied
to the clipboard.

Legend: displays a legend showing the correspondence between variables and colors
used in the plot.

Parameters: shows the parameter values that were in effect when the run was
performed.

Colors: toggles the use of different colors on and off.

Dashed Lines: toggles the use of different line styles on and off.

Data Points: draws a dot corresponding to each computed point.

Grid: toggles the grid lines on and off.

Readout: displays coordinates of the selected point when the mouse is clicked and
dragged over the plot.

When you’re done trying out these buttons, click the  (Zoom Out) button until the
original scale showing all of the data is restored.

7. When you have an oscillatory solution such as this, you may want to know the
frequency and amplitude of the oscillations. You can use Berkeley Madonna’s Fast
Fourier Transform feature to get this information. Click the  (FFT) button. Berkeley
Madonna computes the FFT of each variable in the plot and displays the resulting
amplitude over the frequency spectrum. In this example, you can see a clear peak at
f=0.16. If you use the Readout feature while FFT mode is active, both the frequency and
the period corresponding to the readout cursor’s position are displayed. Click the FFT
button again to return to the time-based plot.

8. In the parameter window, select STOPTIME and click the Reset button to reset it to it’s
original value. Then, change the value of k1 to 0.01 and k2 to 100. Then, run the model.
At first glance it appears that the amplitude of A and B are the same. However, if you
look closely you’ll see that A and B are plotted on separate scales (A on the left, B on the
right) and that their actual amplitudes are quite different.

9. While holding the shift key, click on the button labeled B below the plot. Now, A and B
are plotted on the same Y axis with the same scale. Shift-clicking a “variable button”, as



the buttons at the bottom of the plot are known, moves the selected variable from one
Y axis to the other.

10. While holding down the option key (Macintosh) or control key (Windows), click the A
button. Now the scales are adjusted to optimally display the A variable. As a result, the
B variable is now going past the boundaries of the plot. Option/control-clicking a
variable button adjusts the scale of the X and Y axes to match the range of the selected
variable.

11. You can manually set axis scales using the Scales page of the Axis Settings dialog (Graph
menu). This dialog can also be displayed by double-clicking on any of the plot’s axes. In
this case, you’ll see that the X and left Y axis scales have been manually set (this
happened when you optimized the scaling for the A variable). Turn on Auto-scale
mode for the X and left Y axes and click OK. Now both curves fit entirely within the
boundaries of the plot.

12. Berkeley Madonna can display the results of multiple runs simultaneously on the same
plot. This makes it easier to see how a parameter change affects your model. In the
parameter window, set STOPTIME to 100 (not 1000). k1 and k2 should still be set to 0.01
and 100, respectively. Run the model. Next, change the k1 parameter to 0.02. Then, click
the  (Overlay Plots) button in the graph. Run the model again. You’ll see the results
of both runs in the graph. If you turn on the legend, you’ll see that four curves are
plotted, two (A and B) for each run. Click the A button below the plot to remove A
from the plot, leaving only the two B curves. Finally, click the FFT button to see how
the frequency of oscillation increased in the second run.

13. As long as Overlay Plots remains enabled, Berkeley Madonna will continue to add new
runs to the plot instead of removing the old run(s) first. You can manually remove old
runs while leaving Overlay Plots enabled by using the Discard Last Run and Discard All
Runs commands in the Graph menu.

14. Changing parameters from the keyboard can be tedious, so Berkeley Madonna provides
an alternative called sliders. Choose Define Sliders from the Parameters menu and add
both parameters (k1 and k2) to the list. Enter reasonable minimum, maximum, and
increment values for each (0.0, 2.0, 0.1). Berkeley Madonna displays a floating window
with one slider for each parameter. Try dragging one of the sliders. When you release it,
Berkeley Madonna adjusts the parameter value and automatically runs your model. If
you hold down the option key (Macintosh) or control key (Windows) while releasing
the slider, Berkeley Madonna adjusts the parameter value but does not run your
model.



Building a Visual Model

In the previous section, you learned how to create models by entering text into Berkeley
Madonna’s equation window. In this section, we’ll construct a model graphically using the
flowchart editor. The model will consist of three elements: a reservoir icon (integrator)
representing the population, a flow icon representing deaths in the population, and a
formula icon representing the rate of decay.

Before starting, verify that the flowchart editor is functioning properly. To do this, choose
About Berkeley Madonna from the Help menu and look for text that reads “Flowchart
version 8.0.1”. If it says “Java not loaded”, click the Load Java button. If Java fails to load,
you need to install (or perhaps reinstall) Java support on your system. See the Read Me
document for details.

1. Choose New Flowchart from the File menu. An empty flowchart window appears.

2. Position the mouse over the reservoir tool , press the mouse button, drag the
reservoir to the flowchart, and release the mouse button. You’ve now placed a
reservoir on the flowchart with the default name “R1”. Note that the reservoir is
colored red which means it’s selected.

3. Change the name of the reservoir to “Population” by typing the new name. It is not
necessary to first click the reservoir since it is already selected.

4. Click the flow tool , move the mouse over the Population reservoir, press the
mouse button, drag the mouse to the right a few inches, and release the mouse button.
This places a flow icon on the flowchart which drains the Population reservoir into an
infinite sink.

5. Make sure the reservoir is connected to the flow. If the flow looks like this:

it’s source end is not connected to the reservoir. In this case, drag the infinite source to
the reservoir and drop it. This connects the flow’s input to the reservoir instead of an
infinite source.

6. You may find that the icons are not positioned the way you want. They can be
repositioned by clicking and dragging. Note that Berkeley Madonna maintains the
connection between the reservoir, flow, and sink.

7. Change the name of the flow to “Deaths” by clicking the flow if it is not already selected
and typing the new name.



8. Place a formula icon  on the flowchart approximately halfway between the
reservoir and flow icons (use the same click and drag technique as you did for the
reservoir). Change the name of the formula icon to “Death Rate”.

9. Click the arc tool  and create an arc going from the reservoir icon to the flow
icon (use the same technique as you did for the flow). This creates a dependency
relationship between the flow and the reservoir: the number of deaths depends on the
population.

10. Create another arc going from the formula icon to the flow icon. This makes the
number of deaths depend upon the death rate constant in addition to the population.

11. Double-click the Population reservoir. This opens a dialog box for the reservoir. In this
dialog, you specify the reservoir’s initial value. In this case, enter 1000 and click OK.
Note that the question mark inside the reservoir icon disappears after the dialog has
been dismissed. This means that the equations for this reservoir are fully specified.

12. Double-click the Death Rate formula to open it’s icon dialog. Enter 0.02 for the
formula’s right-hand side and click OK.

13. Double-click the Deaths flow. Note that “Population” and “Death Rate” are required
inputs. This means that these variables must be used in the right-hand side of the
equation defining the icon’s value. Enter the following formula for the right-hand side:
“Population * Death_Rate”. Note that instead of typing names of required inputs, you
can double-click on the input’s name in the list to insert that name. And you can use
the calculator keypad to insert digits and common arithmetic operators. Click OK when
done.

14. Your model’s flowchart is now complete and should now appear something like this:

Now run your model by choosing Run from the Compute menu. Berkeley Madonna
runs your model and displays the results in a graph window.

15. You can change the curvature of the dependency arcs by dragging their control points.
To do this, first select an arc by clicking somewhere along its trajectory. The arc will
turn red and a small square handle (control point) will appear. Click and drag the
control point to change the arc’s trajectory.



16. Icons and arcs can be removed by selecting them and choosing Clear (Macintosh) or
Delete (Windows) from the Edit menu. You can also remove selected objects by holding
down the control key while pressing the delete or backspace key. Try deleting the arc
from the Population reservoir to the Deaths flow. Note that a question mark reappears
in the flow icon. That’s because the icon’s equation refers to the Population variable
which is no longer a dependent. You can easily reestablish this dependency by drawing
a new arc from the reservoir to the flow.

17. Now that you’ve seen how easy it is to create a model, you should take a look at the
equations Berkeley Madonna generated for you. To do this, choose Equations from the
Model menu. Position the equations along side the flowchart so that you can see both
windows simultaneously.

18. Select an icon in the flowchart with the mouse. When you select a single icon, Berkeley
Madonna highlights its equation(s) in the equation window. This makes it easy to see
an icon’s equations without opening its icon dialog.

19. Berkeley Madonna can show you which icon corresponds to an equation in the
equation window. To do this, position the equation window’s insertion point (caret)
within one of the equations, then choose Show Icon from the Edit menu. Berkeley
Madonna activates the flowchart window and selects the corresponding icon.

20. Now try editing your equations in the equation window like you did in the first section
of this tutorial. Berkeley Madonna won’t let you. When working with a visual model
(i.e., one that has a flowchart), you cannot edit the equations directly in the equation
window. Instead, you edit each icon’s equations using its icon dialog. The icon dialog
can be opened by double-clicking an icon or choosing Icon Info… from the Flowchart
menu. You can also open the icon dialog directly from the equation window by double-
clicking an equation. For example, double-clicking anywhere within the line “Deaths =
Population * Death_Rate” opens the icon dialog for the Deaths flow.

21. Select the Population reservoir, type “Molecules” and press return. The name of the
icon changes and Berkeley Madonna updates the name in all equations that depend on
it. To see this in action, change the name again and keep your eye on the equation
window as you press the return key.

That’s it for this tutorial. You now know enough to get started building your own models
with Berkeley Madonna.


